易语言如何随机提取数组的成员

RT。 或者。取随机数,如果使这次取的,不会与上几次相同。也就是如果取到同一个了。自动再次取。
随机取数组成员解决方法

1、首先置随机数种子

2、取出数组成员数

3、用取随机数方法取一个1到数组成员数之间的一个值做索引

4、读取索引处成员

代码实例

.版本 2
.支持库 spec

.子程序 __启动窗口_创建完毕
.局部变量 数组, 整数型, , "0"
.局部变量 成员数, 整数型
.局部变量 索引, 整数型

数组 = { 56, 66, 99, 33, 67, 334 }
置随机数种子 ()
成员数 = 取数组成员数 (数组)
索引 = 取随机数 (1, 成员数)
调试输出 (数组 [索引])

发表回复

您的电子邮箱地址不会被公开。